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Citrix Integration Failure Due to Invalid Okta API Token Causes Empty Dashboard
API Access Management
Okta Classic Engine
Okta Identity Engine
Overview

When the Application Programming Interface (API) token used by the Citrix integration is revoked or expires, users will see an empty dashboard in the Citrix Workspace. Because the Citrix Cloud console does not support editing an existing API key, a new API token must be generated in Okta and used to reconfigure the connection.

Applies To
  • OpenID Connect
  • API Access Management
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
Cause

The Okta API Token used by the Citrix integration to retrieve groups and grant access to users is either revoked or invalid.

Solution

Follow these steps to generate a new API token in Okta and apply it to the Citrix Cloud configuration:

  1. Log in to the Okta Admin Console with an account that has at least Read-Only Administrator privileges.
  2. Navigate to Security > API.
  3. Select the Tokens tab and click Create Token.
  4. Name the token and click Create Token.
  5. Click on the Copy to clipboard button to copy the token value. If the window is closed without saving the token, a new one must be created.

Copy Token

  1. Reconfigure the Citrix Cloud connection and apply the new API token by following the steps mentioned in the Connect Okta as an identity provider to Citrix Cloud documentation.
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Citrix Integration Failure Due to Invalid Okta API Token Causes Empty Dashboard