Okta Cisco Webex Provisioning Error "PATCH failed: HTTP/1.1 400 Bad Request url = https://domain.webex.com, request/response TrackingId = <value>, error = 'addresses.region length must be between 1 and 64"
Last Updated:
Overview
The Okta Cisco Webex provisioning flow fails when an unsupported attribute, such as the address region, is mapped in the integration. Remove the unsupported attributes from the Okta mapping and retry the failed task to resolve the issue. When this occurs, Okta displays the following error in the dashboard:
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Cisco Webex
- Provisioning
Cause
The Webex System for Cross-domain Identity Management (SCIM) server reports the error when performing a PATCH request. Based on the error, the Addresses > Region attribute value causes the issue. According to Cisco Webex's documentation, the Webex Okta integration supports only the following attributes: userName, displayName, name.familyName, name.givenName, externalId, and title.
Solution
Remove the unsupported attributes from the Okta mapping and retry the failed tasks in the Okta Admin Console.
- Remove the unsupported attributes from the Okta mapping or remove the update from the sync configuration.
- Go to the Okta Admin Console and navigate to Dashboard > Tasks.
- Locate the failed task for the user.
- Select Retry Selected.
NOTE: If the issue persists, contact Webex support for more details about the error message. Occasionally, the Webex system stores the attribute value on the backend, which might need to be manually cleared.
