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Cannot Modify or Delete Okta Attributes Due to Read-Only Permissions

Okta Identity Engine
Universal Directory

Overview

This article explains the errors that occur when attempting to remove or edit an Okta attribute. When a user attempts to modify an attribute with read-only permissions, the following error may occur:

 

L10N_ERROR[profile.identification.table.delete.error]

 

Additionally, the following sibling errors may occur when attempting to edit or delete the attribute immediately after switching the permissions from read-only to read-write:

 

Error Code: E0000077HTTP Status: 403 Forbidden Message: Cannot modify the <attribute_name> attribute because it is read-only.

Error Code: E0000078 HTTP Status: 403 Forbidden Message: Cannot modify the <attribute_name> attribute because it is immutable.

 

Applies To

  • Universal Directory (UD)
  • Profile Editor
  • Okta Identity Engine (OIE)
  • Attributes

Cause

The L10N_ERROR[profile.identification.table.delete.error] error occurs because a Universal Directory (UD) base attribute is set to read-only.

 

The forbidden errors (E0000077 and E0000078) may occur when attempting to edit or delete the attribute immediately after switching the permissions from read-only to read-write. The system registers the attribute slightly differently during the specific polling window, which causes these errors to appear if modifications are attempted too quickly before the system fully registers the change.

Solution

To resolve these errors, follow the steps mentioned below:

  1. Change the User permission level of the attribute to Read-Write using the Profile Editor.
  2. Wait a short time for the polling window to complete and the system to register the permission change.
  3. Modify or delete the attribute.

 

NOTE: Any UD attribute used in the profile enrollment form must have a User permission setting of Read-Write to allow users to update its value during sign-in. If a UD attribute has a User permission of Hide or Read Only, the enrollment form is disabled, and changes cannot be made until the User permission level is updated using the Profile Editor.

 

Related References

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Okta Support - Cannot Modify or Delete Okta Attributes Due to Read-Only Permissions