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BambooHR Import Error "An error occurred during import Error while downloading all groups: API key not provided or invalid"

Okta Classic Engine
Okta Identity Engine
Okta Integration Network

Overview

BambooHR import fails with the following error:

 

An error occurred during import Error while downloading all groups: API key not provided or invalid

 

BambooHR app import

Applies To

  • BambooHR
  • Import

Cause

The BambooHR account credentials used to enable the provisioning connector between Okta and BambooHR are not valid.

Solution

  1. Go to Okta Admin Console and navigate to Applications > Applications > BambooHR > Provisioning > Integration > Edit.
  2. Access the Provisioning tab of the BambooHR integration.
  3. Click on the Integration section and click Edit.
  4. Click on the Authenticate with BambooHR button. Ensure to use a BambooHR account with the necessary permissions.
  5. After the authentication flow is successful, click Save.
  6. Then navigate to Applications > Applications > BambooHR > Import > attempt the import again.
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Okta Support - BambooHR Import Error "An error occurred during import Error while downloading all groups: API key not provided or invalid"