BambooHR Import Error "An error occurred during import Error while downloading all groups: API key not provided or invalid"
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Overview
BambooHR import fails with the following error:
An error occurred during import Error while downloading all groups: API key not provided or invalid
Applies To
- BambooHR
- Import
Cause
The BambooHR account credentials used to enable the provisioning connector between Okta and BambooHR are not valid.
Solution
- Go to Okta Admin Console and navigate to Applications > Applications > BambooHR > Provisioning > Integration > Edit.
- Access the Provisioning tab of the BambooHR integration.
- Click on the Integration section and click Edit.
- Click on the Authenticate with BambooHR button. Ensure to use a BambooHR account with the necessary permissions.
- After the authentication flow is successful, click Save.
- Then navigate to Applications > Applications > BambooHR > Import > attempt the import again.
