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AWS IAM Identity Center Provisioning Error: "Automatic provisioning of user <name of user> to app AWS IAM Identity Center failed: Matching user not found."
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

AWS IAM Identity Center application provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <name of user> to app AWS IAM Identity Center failed: Matching user not found
Applies To
  • AWS IAM Identity Center 
  • Provisioning 
  • Error 
Cause

Create User setting under the Provisioning tab in the To App settings is disabled. When disabled Okta cannot create or link a user in AWS IAM Identity Center when assigning the app to a user.

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > AWS app > Provisioning > To App > Provisioning to App
  2. Click the Edit button and enable Create Users
  3. Save the changes.
  4. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.  
  5. After identifying the failed task for the user, click on Retry Selected
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AWS IAM Identity Center Provisioning Error: "Automatic provisioning of user <name of user> to app AWS IAM Identity Center failed: Matching user not found."