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Salesforce Federated ID Provisioning Error "Username must be in the form of an email address: Username; This Federation ID is already in use"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

When provisioning a user to Salesforce Federated ID, the following error arises:

Automatic provisioning of user <user> to app Salesforce.com (Federated ID) failed: Username must be in the form of an email address (for example, john@acme.com): Username; This Federation ID is already in use. Use a different Federation ID.: SAML Federation ID


Salesforce 

 
Applies To
  • User Lifecycle Management
  • Salesforce Federated ID
  • Provisioning
Cause
This is because the username is not in the format of an email address, and the Federation ID for the user is in use by another user.
Solution
  1. Change the username being passed to an email format type: john@acme.com.
  2. The Federation ID for the provisioned user already exists. Change the federation ID to a unique value.
  3. Attempt to provision the user again and confirm they have been successfully provisioned.
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Salesforce Federated ID Provisioning Error "Username must be in the form of an email address: Username; This Federation ID is already in use"