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Attributes are Missing from the Salesforce Integration
Okta Integration Network
Okta Classic Engine
Overview

This article provides instructions on how to bring missing attributes into the Salesforce integration.
 

The Salesforce integration missing the attributes is in the list below:
 

Title

title

Nickname

communityNickname

Cell

mobilePhone

Phone

phone

Street

street

City

city

State/Province

state

Zip/Postal Code

postalCode

Employee Number

employeeNumber

Company Name

companyName

Division

division

Department

department

Manager

managerId

Feature Licenses

featureLicenses

Role

role

Permission Sets

salesforceGroups

Public Groups

publicGroups

Applies To
  • Okta Classic Engine
  • Salesforce
  • Provisioning
Cause

A common cause is that an administrator mistakenly deleted an attribute. When an attempt is made to add the attribute back through the Pick Schema Attributes, it does not appear.

Solution

If there are multiple Salesforce integrations and one of them is missing, for example, the attribute public groups, previously the attribute was displayed, but currently, it is not showing, the first step is to make sure that the API connector is working as intended and there are no restrictions.


Follow the steps or watch the video below to determine if the Service account was previously used to establish proper communication between Okta and Salesforce and vice versa.


 

  1. Create an administrator account in Salesforce.
  2. In the Admin Console, go to Applications > Applications.
  3. In the search field, enter Salesforce and click Salesforce.com.
  4. Click the Provisioning tab and click Configure API Integration.
  5. Select the Enable API integration check box.
  6. If the instance is configured to use OAuth, enter the OAuth Consumer Key and OAuth Consumer Secret, then click Authentication with Salesforce.com. For more details, see Configure OAuth and REST integration.
  • To avoid breaking the integration, use a dedicated API account to connect Okta to Salesforce: Do not use the Salesforce admin account, even if the account has the Global Admin role.
  • Do not enable delegated authentication in Salesforce for the API user specified here.
  1. Optional: Select the Allow Pushing Null Values check box to allow null values to be pushed from Okta to Salesforce.
  2. Optional. Click Test API Credentials to test the API integration.
  3. Click Save.

After the API connector is working as intended and the attribute is still not showing in the list, schedule a maintenance window outside working hours and follow the steps :

  1. Uncheck the Create Users, Update User Attribute, Deactivate Users, and Sync Password.
  2. Test the API credentials to see that provisioning is working properly.
  3. Disable (deactivate) the integration, refresh the page, and re-enable (re-activate) the integration.
  4. Test the API credentials to see that provisioning is working properly.
  5. Check to see if this brings back the attribute.

If this procedure is still not bringing the attributes in, please open a support case.

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Attributes are Missing from the Salesforce Integration