Armis App Provisioning Error "Error while verifying if user exists: Internal Server Error. Errors reported by remote server: A problem occurred. Try again in a few minutes."
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Armis Provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Armis failed: Error while verifying if user <username> exists: Internal Server Error. Errors reported by remote server: A problem occurred. Try again in a few minutes. 

 

Applies To
  • Armis
  • Provisioning
  • Error
Cause

This error can be caused if the API token used in the Armis Application API integration is invalid. 

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > Armis > Provisioning > Integration > Edit.
  2. Enter the API Token generated in Armis in the API Token field.
  3. Click Test API Credentials, verify the successful connection, and click Save.
  4. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks

  1. After locating the failed task for the user that should be retried, click on Retry Selected.

Recommended content

No recommended content found...