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Application Icon Is Not Visible on Dashboard with Federation Broker Mode Enabled
Okta Classic Engine
Okta Identity Engine
API Access Management
Overview

This article addresses an issue where an application icon does not appear on a user's Okta End-User Dashboard, even when the Display application icon to users setting is enabled. This occurs when Federation Broker Mode is active for the application.

Applies To
  • Custom Security Assertion Markup Language (SAML) Applications
  • Custom OpenID Connect (OIDC) Applications
Cause

This is caused by a known limitation of Federation Broker Mode (FBM). When FBM is enabled, applications are accessible only through Service Provider (SP)-initiated flows and will not appear on the Okta End-User Dashboard. This mode improves performance by removing the need for explicit user assignments, but a side effect is the removal of the application icon from the user's dashboard. The FBM functionality overrides the Display application icon to users setting.

Solution

Since applications with Federation Broker Mode enabled do not appear on the user dashboard by design, a bookmark application must be created to provide users with a clickable icon.

  1. Navigate to the Admin Console and select Applications.
  2. Select Add Application and search for "Bookmark App".
  3. Configure the bookmark to point to the application's sign-in URL.
  4. Assign the bookmark application to the relevant users so they can access the application from their dashboard.

 

Related References

 

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Application Icon Is Not Visible on Dashboard with Federation Broker Mode Enabled