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Zendesk Provisioning "Error while verifying if user exists: 401 Unauthorized: "{"error":"Couldn't authenticate you"}""
Okta Integration Network
Overview

Zendesk provisioning flow fails with the following error visible in the Okta dashboard:
 

Automatic provisioning of user <user> to app Zendesk failed: Error while verifying if user <user> exists: 401 Unauthorized: "{"error":"Couldn't authenticate you"}"

 

Applies To
  • Zendesk
  • Provisioning
  • Error

 

Cause

This error is caused because the Zendesk credentials used for creating the API connection are invalid. 

Solution

To resolve the issue please please follow the video or the steps below: 


 

  1. Go to Okta Admin Console and navigate to Applications > Applications > Zendesk > Provisioning > Integration > click the Edit button.
  2. Type the correct Zendesk credentials based on one of the scenarios below:
    • Scenario 1: Enter the Zendesk agent's email address and password in the Username and Password fields, respectively. Click Test API Credentials and verify that the connection is successful, and then click Save.
    • Scenario 2: If using an API token instead of a password:
      1. Append /token to the end of the agent's email address in the Username field, and paste an "Active API" token into the Password field.
      2. Click Test API Credentials and verify the connection is successful, then click Save.

Integration

  1. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks
  2. After identifying the failed task for the user that should be retried, click on Retry Selected.
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Zendesk Provisioning "Error while verifying if user exists: 401 Unauthorized: "{"error":"Couldn't authenticate you"}""