Zendesk Provisioning Error "Forbidden: You do not have access to this page. Please contact the account owner of this help desk for further help"
Okta Integration Network
Overview

Zendesk provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <user> to app Zendesk failed: Error while trying to push profile update for <user>: 403 Forbidden: "{<EOL> "error": {<EOL> "title": "Forbidden",<EOL> "message": "You do not have access to this page. Please contact the account owner of this help desk for further help."

Applies To
  • Zendesk
  • Provisioning
Cause

The error is caused by the lack of required permissions on the Zendesk side. 

The Access Denied error message appears when someone attempts to access a page they do not have permission to view.

Solution
  1. To get more help regarding this error and fix the required permissions, please contact Zendesk Support.
  2. Afterward, go to the Okta Admin Console and navigate to Applications > Zendesk > Provisioning > Integration > Edit.
  3. Type the Zendesk credentials.
  4. Click Test API Credentials, verify the connection was successful, and then click Save.

"Test API Credentials" button

  1. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

Task menu

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

 

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