<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Workday Real-Time Sync with Contact Changed Trigger Removing Manager
Okta Classic Engine
Okta Integration Network
Integrations
Overview
With Workday and Real-Time Sync (RTS) enabled with contact changed as a trigger, the manager field is incorrectly being removed. Perform an incremental import, view the user and confirm the manager is populated, watch the system log and see an RTS, and then Okta attribute update performed (expand this action and see the manager field updated).
Applies To
  • Workday and Real-Time Sync (RTS)
Cause
In Workday, contact change is selected as a trigger for real-time sync (RTS). However, the manager field cannot be updated via RTS, which removes the manager from the Okta profile.

Per our documentation, some worker attributes, like the Manager Username, cannot be populated in Okta as part of Real-Time Sync. The workaround is to add the attribute to the Workday field overrides or to the Custom Report (deprecated) configuration.
Solution
  1. Deactivate RTS (real-time sync) in Workday.
  2. Remove contact changed as a trigger for RTS.
  3. Re-enable RTS.
  4. Perform an incremental import.

Related References

Recommended content

Loading
Workday Real-Time Sync with Contact Changed Trigger Removing Manager