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WinSCP Installed for Users Only Cannot Be Detected by sft
Advanced Server Access
Okta Classic Engine
Okta Identity Engine
Overview

This article addresses the "sft winscp <servername>" erring out with Failed to find WinSCP.exe.

The complete error is: 

error: Failed to find WinSCP.exe. Tried: []string{"C:\\Program Files\\WinSCP\\WinSCP.exe", "C:\\Program Files (x86)\\WinSCP\\WinSCP.exe", "C:\\Users\\<username>\\AppData\\Local\\Apps\\WinSCP\\WinSCP.exe"} 

 

Applies To
  • Okta Advanced Server Access (ASA)
  • WinSCP
Cause

Currently, sft winscp (client tools) cannot detect any location apart from the three below:

  • C:\\Program Files\ 
  • C:\\Program Files (x86)\ 
  • C:\\Users\username\AppData\Local\Apps\

WinSCP installation for users-only mode installs by default at:

  • C:\Users\<username>\AppData\Local\Programs\WinSCP\WinSCP.exe, so sft would not be able to detect it. 
Solution

Reinstall WinSCP using any of the installation paths below. A custom installation option will be required to specify the location.

  • C:\\Program Files\
  • C:\\Program Files (x86)\
  • C:\\Users\<username>\AppData\Local\Apps\
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WinSCP Installed for Users Only Cannot Be Detected by sft