<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Veeva Vault API Error "Could not verify the Veeva Vault administrator login and password; please confirm that these are set correctly"
Okta Integration Network
Overview

The Veeva Vault API Credentials test fails with the following error visible in the Okta dashboard:

Could not verify the Veeva Vault administrator login and password; please confirm that these are set correctly.

 

Applies To
  • Veeva Vault
  • Provisioning Error
Cause

The error is due to one of the following: 

  • Under the General tab, the incorrect Veeva Vault URL has been configured. 
  • The Veeva Vault credentials used to create the API connection are invalid.
  • The permissions for the account used to create the API connection are incorrect on the Veeva Vault side. Minimum requirements for API user:
    • The Domain Admin flag should be set to ON.
    • The user should be a Vault Owner or a System Admin.
Solution
  1. Navigate to Okta Admin Console > Applications > Applications > Veeva Vault > General > ensure the correct Veeva Vault URL is configured: 
    Veeva Vault URL  

  2. Navigate to Okta Admin Console > Applications > Applications > Veeva Vault >  Provisioning > Integration > click on the Edit button.

  3. Enter a valid Admin Username and Admin Password.

  4. Click Test API Credentials, verify if the connection was successful, and click Save.

Test API Credentials 

Related References

 
Loading
Veeva Vault API Error "Could not verify the Veeva Vault administrator login and password; please confirm that these are set correctly"