ProxyAddresses Attribute Does Not Sync Okta to Office 365
Last Updated:
Overview
Okta does not sync the ProxyAddresses attribute to Microsoft Office 365 when the application uses specific provisioning types because the attribute requires the Universal Sync option Provisioning option. Specifically, Okta fails to sync the ProxyAddresses attribute when the Microsoft Office 365 application is configured to use Licenses/Roles Management Only, Profile Sync, or User Sync.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Microsoft Office 365 (O365)
- Universal Sync
- ProxyAddresses
Cause
The ProxyAddresses attribute requires the Universal Sync provisioning option in Okta. Okta designed Universal Sync specifically to support Active Directory (AD) schema attributes. Okta does not sync the attribute when the application uses Licenses/Roles Management Only, Profile Sync, or User Sync.
Solution
The ProxyAddresses attribute can only be synced from Okta to Microsoft Office 365 when the Universal Sync provisioning type is enabled (out of the box)
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In the Okta Admin Console, navigate to Applications > Applications.
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Click the affected Microsoft Office 365 application.
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Click the Provisioning tab and select the To App section.
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Ensure that Universal Sync is checked.
For environments where Active Directory is not used but adding alternate emails (proxy addresses are required) please refer to:
