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Unable to Edit "/etc/hosts" in the Okta Access Gateway Management Console
Access Gateway
Overview

The Okta Access Gateway (OAG) management console may fail to load the Edit /etc/hosts screen or allow adding additional entries.

 

To reproduce the issue

  1. SSH to OAG node.
  2. Select 1 - Network.
  3. Select 3 - Edit /etc/hosts.
  4. Instead of the Edit /etc/hosts screen loading, the Access Gateway Network Setup screen remains displayed with the character "3" now across the top row.
  5. The Edit /etc/hosts screen may load, but attempting to add another entry results in returning to the Access Gateway Network Setup screen.
Applies To
  • Okta Access Gateway (OAG)
  • Management Console
Cause

This occurs when the number of entries in the "/etc/hosts" file exceeds the number that can be displayed in the console window.

Solution

To solve this issue, please consider:

  • Resizing the terminal or PuTTY window to increase the number of rows and/or decrease the terminal font size.
  • Configuring DNS to reduce the number of required entries in /etc/hosts.
  • Modifying /etc/hosts by connecting to the appliance shell and then running the command below to modify the file:
    sudo vi /etc/hosts
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Unable to Edit "/etc/hosts" in the Okta Access Gateway Management Console