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Unable to Edit Custom SAML App
Single Sign-On
Okta Classic Engine
Overview

When editing a custom SAML application in the Admin console, selecting the Next button under the General Settings screen results in the following error:

 

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SAML integration 

Applies To
  • Custom SAML App
  • Application Integration Wizard (AIW)
  • Secure Assertion Markup Language (SAML)
Cause

This issue is due to a validation process when editing the SAML Application. If in the Application Username field when set to Custom an expression is present that uses the old Okta expression language (for example, ${f:substringBefore(user.email, "@")}), or if the field is blank, the username validation will result in empty values, and Okta will return an error.

Solution

Follow the video or the steps below.

  1. Open the Custom SAML app as an admin.
  2. Click the Sign On tab.
  3. Click Edit.
  4. Update the Application username format to use a predefined value or use a custom expression using the latest Okta Expression Language, for example, String.substringBefore(user.email, "@").

For example, if the Service Provider requires all usernames to be set to the same value, and the current custom username format reads SSOUsername, this must be updated so that the string is wrapped in either single or double quotes, such as SSOUsername or SSOUsername, in order to follow EL requirements.

 

Invalid Expression Language

Valid Expression Language

credentials details

credentials details

  1. Save the changes.
  2. Click the General tab.
  3. Click Edit for SAML Settings.
  4. Click Next.

 

Related References

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Unable to Edit Custom SAML App