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Unable to Sign In after Adding Read-Only Custom Required Attributes in the User Profile
Okta Identity Engine
Administration
Overview
After adding Custom Required Attributes in the User Profile, and this attribute is set to Read-Only, users are unable to sign in. The following error is shown:

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Applies To
  • Okta Identity Engine
Cause

Custom Required Attributes must be set to Read-Write. After creating a Custom Required attribute, this is immediately added to the Profile Enrollment Policies to keep the Universal Directory consistent.
 

Even when creating a Custom Required Attribute in Read-Only mode, the Admin dashboard informs that it will cause a conflict.
 

Error message

 

Solution
  1. If unable to Sign In, the option is to modify the User Profile by running API Calls.

  2. Use Get User Schema to get the current Profile information and identify the Read-Only Custom Required Attribute that is causing the problem.

  3. Later, use the  Remove property from User Profile Schema to remove the Read-Only Custom Required Attribute.

  4. After this change, retry the Sign In to Okta.

Related References

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Unable to Sign In after Adding Read-Only Custom Required Attributes in the User Profile