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Troubleshooting Failed Active Directory Delegated Authentication Attempts in Okta
Okta Classic Engine
Directories
Okta Identity Engine
Overview

When a user attempts to log in to Okta using Active Directory (AD) via Delegated Authentication, the authentication may fail when the Active Directory Domain Controller rejects the authentication request and returns an error code.

 

When this occurs, Okta generates an event in the Okta System Log labeled "Authenticate user via AD agent" with a status of Login Failed. The event contains the error code provided by AD.

 

Administrators can identify the root cause of the failure by reviewing the Okta System Log event for the specific error code and applying the corresponding fix based on the response from AD.

 

Okta System Log - Authenticate user with AD agent FAILURE - Login Failed

Applies To
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Directories
  • Active Directory (AD)
  • Delegated Authentication
Cause

The Domain Controller rejects the authentication request and returns an error code indicating the failure reason.

Solution

How are Delegated Authentication failures identified?

 

To identify the specific error that the Domain Controller produced, navigate to the Okta System Log and locate the error code by performing the following actions:

 

  1. In the failed authentication event, expand Event.
  2. Expand System.
  3. Expand DebugContext.
  4. Expand DebugData.
  5. Locate the ErrorCode that corresponds to the Active Directory authentication error code.
    • In this example, the error code is 1329.
System Logs Event

 

Review the following list of common Active Directory authentication error codes to determine the reason for the failure:

 

Error Code

Error Description

Note

1326 - ERROR_LOGON_FAILURE

Logon failure: unknown username or bad password

Returns when the username is valid but the password/credential is invalid.

1328 - ERROR_INVALID_LOGON_HOURSLogon failure: account logon time restriction violation

Returns only when presented with a valid username and password/credential.

1329 - ERROR_INVALID_WORKSTATIONLogon failure: user not allowed to log on to this computer

Returns only when presented with a valid username and password/credential.

1330 - ERROR_PASSWORD_EXPIREDLogon failure: the specified account password has expiredReturns only when presented with a valid username and password/credential.
1787 - ERROR_NO_TRUST_SAM_ACCOUNTThe security database on the server does not have a computer account for this workstation trust relationship.None
1789 - ERROR_TRUSTED_RELATIONSHIP_FAILUREThe trust relationship between this workstation and the primary domain failed.None
1793 - ERROR_ACCOUNT_EXPIREDThe user's AD account has expired.Returns only when presented with a valid username and password/credential.
1907 - ERROR_PASSWORD_MUST_CHANGEThe user's password must be changed before logging on for the first time.Returns only when presented with a valid username and password/credential.
1909 - ERROR_ACCOUNT_LOCKED_OUTThe referenced account is currently locked out and may not be logged on to.Returns even if an invalid password is presented.

 

NOTE: Okta does not return these error codes. They reflect the response of the Active Directory Domain Controller that validates the credentials during the user login via Delegated Authentication.

 

For a complete list of system error codes, review the following Microsoft documentation.

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Troubleshooting Failed Active Directory Delegated Authentication Attempts in Okta