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TravelPerk Provisioning "Error while creating user : Conflict. Errors reported by remote server: A user with userName already exists. The userName must be unique"
Okta Integration Network
Overview

TravelPerk's provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <user> to app TravelPerk failed: Error while creating user <user> : Conflict. Errors reported by remote server: A user with userName "<username>" already exists. The userName must be unique.
 

Error Message

Applies To
  • TravelPerk
  • Provisioning
  • Error
Cause

The user with the same username already exists in the TravelPerk account. The userName must be unique.

Solution
  1. Resolve the conflict by using one of the two options below:

    • Option 1: Deleting the existing user with the conflicting username on the TravelPerk side.
    • Option 2: Changing the username of the user who should be assigned to the TravelPerk app in Okta.
  1. After confirming that the conflict has been resolved, attempt user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

Tasks

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

NOTE: If the issue persists, please contact TravelPerk support for more details and steps to resolve this error.

 

Related References

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TravelPerk Provisioning "Error while creating user : Conflict. Errors reported by remote server: A user with userName already exists. The userName must be unique"