<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
AD User Is Continually Prompted for the Security Question
Okta Classic Engine
Okta Identity Engine
Administration
Overview

An end-user continually gets prompted for the Security Question for Self Service Recovery on the Okta Welcome page. This article explains why and how to resolve this issue.

Applies To
  • Security Question
  • Secondary Email
Cause

If the Optional User Account Fields (Security Image and Secondary Email) option is enabled, the user will be redirected to the Okta Welcome Page. This usually happens if the Secondary Email option is enabled after the user was created/imported in Okta.

Solution

If the end-user is getting prompted for the Okta Welcome Page unexpectedly, please follow the steps below:

  1. In the Admin Console, navigate to the Customization tab.
  2. Select Other and look for Optional User Account Fields:
    • For Okta Classic Engine

Optional User Account Fields in Okta Classic

    • For Okta Identity Engine (OIE)

Optional User Account Fields in OIE

  1. Based on the enabled options, please ensure the user has the required factors configured. 

 

Related References

Loading
AD User Is Continually Prompted for the Security Question