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Slack SSO Error "There's been a glitch..."
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

The Single Sign-On (SSO) flow initiated from the Okta dashboard fails on the Slack page with the following error:

There's been a glitch...
We're not quite sure what went wrong. You can go back, or try looking on our Help Center if you need a hand.

 

Error Message

Applies To
  • Slack
  • Single Sign-On (SSO)
Cause
The failure of the SSO flow usually stems from a misconfiguration in Slack's SSO integration. Specifically, one commonly overlooked step is enabling the “Sign AuthNRequest” option in Slack's settings, a requirement according to SSO documentation.
Solution

To fix this issue, verify that the Sign AuthNRequest option is enabled on Slack's side. This can typically be found in Slack's SSO or authentication settings. If the issue persists after verifying this setting, review the overall SSO integration configuration for Slack and correct any discrepancies.

If the Slack tenant URL does not follow the “https://domain.slack.com” format, but is similar to “https://domain.enterprise.slack.com”, it needs to be added in Okta to reflect the “.enterprise” portion.
To adhere to this format, on the General tab in Okta, add “domain.enterprise” instead of just “domain“ to the Domain field.

"Sign AuthNRequest” option


Related References

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Slack SSO Error "There's been a glitch..."