Slack Provisioning Error: "Errors reported by the connector : {"Errors":{"description":"Invalid managerId (user=)","code":400}}. Error Code: null"
Okta Integration Network
Overview

Slack provisioning flow fails with the following error visible in the Okta dashboard:

Error executing pushUserProfile: Bad Request. Errors reported by the connector : {"Errors":{"description":"Invalid managerId (user=xxxxx)","code":400}}. Error Code: null

 

error

In Directory > Profile Editor > Slack User > Mappings, the managerId attribute has the Okta User to Slack mapping as shown below:

mappings

Applies To
  • Slack
  • Provisioning
Cause

This error is received because the user.manager in Okta User Profile is not their manager's valid Slack id, primary email, or userName attribute.

Solution
  1. Slack is expecting a valid manager ID value from Okta.

  2. The Manager attribute is referred to as enterprise.manager.managerId, similar to the Manager attribute (managerId) mapped in Okta. Refer to Provisioning with SCIM

    mappings 

  3. As per Slack API doc Provisioning with SCIM, the value for the managerId sub-attribute can be their valid Slack ID, primary email, or userName attribute.
    attribute 

  4. Check if the Okta User Profile user.manager attribute has their manager's valid Slack ID, primary email, or userName that Slack expects.

  5. Once confirmed, attempt the user provisioning again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.
  6. After locating the failed task for the user that should be retried, click on Retry Selected.

 

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