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ServiceNow API Error "Verification failed: ClientProtocolException null"
Okta Integration Network
Overview

ServiceNow API Credentials test flow for ServiceNow API integration fails with the following error visible in the Okta dashboard:

Verification failed: ClientProtocolException null
 

Error Message

Applies To
  • ServiceNow
  • Provisioning
  • Error
  • API
Cause

The ServiceNow administrator credentials are correct, but the Base URL is incorrect (under the General tab of the ServiceNow application in Okta).

Solution
  1. Go to Okta Admin Console and navigate to Applications > Applications > ServiceNow > General tab > verify if the Base URL is correct.

Base URL field

  1. Then navigate to Applications > Applications > ServiceNow > Provisioning > Integration > click the Edit button.
  2. Type the correct ServiceNow Admin credentials and click Test API Credentials
  3. Verify the connection is successful, and then click Save.


Related References

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ServiceNow API Error "Verification failed: ClientProtocolException null"