RingCentral Provisioning Error "Feature [Bulk Assign] is not available. Error Code: FeatureNotAvailable"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

RingCentral provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Ring Central failed: Error while creating user <username>: Errors during execution: Error executing createNewUser: Error from telephone provider: Feature [Bulk Assign] is not available. Error Code: FeatureNotAvailable
 

Error Message

Applies To
  • RingCentral
  • Provisioning
  • Error
Cause

This error appears when the "Bulk Assign" feature is not available in the RingCentral environment.

Solution
  1. Enabling the "Bulk Assign" feature might be required. Log in to the admin RingCentral account and navigate to Tools > Directory Integration > Google Cloud Directory or SCIM, and then enable the "Bulk Assign" feature. If the option is not visible, please contact RingCentral support.
  2. After enabling the "Bulk Assign" feature in RingCentral, attempt user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks 

  1. After identifying the failed task for the user that should be retried, click Retry Selected.


Related References

Recommended content

No recommended content found...