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Profile Mappings Not Updating an Okta User Profile Attribute when Imported via JIT from External IDP
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview

Just-in-Time (JIT) provisioning from an external Identity Provider (IdP) does not update user attributes. This occurs even when the profile sourcing and profile mappings are configured correctly for the external IdP. JIT provisioning functions as expected when creating a new user from the IdP.

Applies To
  • JIT Provisioning
  • Inbound SAML
  • Org2Org
  • Attribute Level Sourcing
Cause

Attribute-level sourcing is incorrectly configured.

Solution
  1. In the Okta Admin Console, go to Directory > Profile Editor.
  2. Click Okta User (default) to edit the Okta profile.
  3. Click the i button (for a predefined attribute) or the pencil icon (for a custom attribute) next to the attribute that needs to be updated via JIT provisioning from the inbound IdP.
  4. In the Source priority field dropdown, select Override profile source.
  5. In the Add source dropdown, select the name of the inbound IdP.
    Inbound IdP   
    NOTE: Multiple profile sources can be added using the dropdown. Priorities can be defined by dragging and dropping the sources as needed if there are multiple sources for the attribute.

 

Related References

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Profile Mappings Not Updating an Okta User Profile Attribute when Imported via JIT from External IDP