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Prevent Daily Username Changes in SAML Applications
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

This article provides a solution for preventing daily username changes in Security Assertion Markup Language (SAML) applications when usernames should not be updated by the application. Adjusting the mappings and updating the settings ensures that usernames do not revert daily, thus reducing the need for manual intervention.

Applies To
  • Okta Administrators
  • SAML Applications
Cause
The application synchronizes out-of-date data to Okta, which is then updated with old information because the affected attribute is set to apply mapped attributes when both creating and updating.
Solution
  1. Navigate to the Okta Dashboard and go to Directory > Profile Editor.
    Profile Editor  

  2. Find the User profile for the SAML application and click on Mappings.
    Mappings  

  3. Select Okta User to Application User mapping.
    Org2Org profile mappings   

  4. Check if the arrow for the username attribute is set to "Apply mapping on create" or "Apply mapping on create and update".
    attribute mapping  

  5. If it is set to "Apply mapping on create and update", change the setting to Apply mapping on create only.


Alternatively, if the application has a specific username setting:

  1. Navigate to the Applications tab in the Okta Dashboard.
    Applications menu  

  2. Select the SAML application and click on the Sign-On tab.
    Org2org App - Sign On tab  

  3. Find the Update application username on setting and change it to Create only.
    " Update application username on" setting  
     

Following these steps prevents SAML applications from syncing the username format, thus avoiding the need for manual intervention.

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Prevent Daily Username Changes in SAML Applications