Perimeter 81 Provisioning "Error while creating user: Unprocessable Entity. Errors reported by remote server: VALIDATION_ERROR"
Okta Integration Network
Overview

Perimeter 81 provisioning flow fails with the following error visible in the Okta dashboard:
 

Automatic provisioning of user to app Perimeter 81 failed: Error while creating <username> :Unprocessable Entity. Errors reported by remote server: VALIDATION_ERROR.
 

error

 

 
Applies To
  • Perimeter 81
  • Provisioning
  • Error
Cause
  • This error is thrown because the Name field contains special characters, such as @, (), #, $, ".", and !. 
special characters
  • According to Perimeter 81 documentation, only a-z, A-Z, and 0-9 are supported for the Name field.

For more details, please consult perimeter 81 - Understanding SCIM for OKTA.

Solution
  1. Go to Okta Admin Console and navigate to Directory > People. Search for the user for whom provisioning to app Perimeter 81 failed. Go to the Profile tab and click the Edit button.
  2. Remove special characters in Name (Ex: "@", "()", "#", "$", ".", and "!". ). For example, First name is "Test M.". Here, a period "." will be the cause; it is a special character. Remove the period "." in the First name. 

NOTE: If provisioning is enabled for other downstream applications, the user's name change may be pushed to them.

test user

  1. Then navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

tasks

  1. After identifying the failed task that should be retried, tick the corresponding checkbox and click on
    Retry selected.

tasks

  1. If the issue persists, please contact Perimeter 81 support for more details and steps to resolve this error.


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