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Outlook Client Keeps Prompting for Credentials
Single Sign-On
Okta Classic Engine
Overview
When logging into an Outlook mail client on a Mac, a user is prompted to authenticate via Okta and is successfully authenticated. Shortly after, the Outlook credential prompt window continues to reappear even though the user has already authenticated.
 
Applies To
  • Office 365
  • Outlook Thick Client
  • Mac workstations
  • Okta Classic Engine
Cause

Stale credentials or token corruption in the local Keychain Access application, where the user's credentials are cached.

Solution

Delete any cached Microsoft passwords and reboot.

  1. Open the Keychain Access program.
  2. In the Keychain search, enter adal.
  3. Delete any Microsoft-related items that are returned in this search.
  4. In the Keychain search, enter office.
  5. Delete any Microsoft-related items that are returned in this search.
  6. Reboot the machine.
  7. Open Outlook and re-authenticate as the end user.
    Keychain Access 
 
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Outlook Client Keeps Prompting for Credentials