<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Org2Org Sync Issue for User with a Slash in ID
Single Sign-On
Okta Classic Engine
Overview

An issue may arise when using Org2Org provisioning if a username contains a forward slash ("/") prior to the "@" character. Despite this character being permissible according to the "Allowed Characters" documentation, provisioning may fail when the Org2Org app is assigned to a user with such a username. The failure is usually accompanied by the following error message:
 

Automatic provisioning of user (full name) to app Okta Org2Org failed: Error while verifying if user (username) exists: The endpoint does not support the provided HTTP method

Applies To
  • Org2Org Provisioning 
Cause
The forward-slash ("/") is a URL-sensitive character, which results in issues when passed as an HTTP method during Org2Org provisioning. The username gets escaped, rendering it invalid. For instance, a username like test.sla/sh@okta.com will be read in Org2Org, provisioning as test.sla, making it an invalid username.
Solution

Currently, there is no direct fix for this issue, primarily because a forward slash in a username can be valid in contexts other than provisioning. As such, the recommended course of action is to avoid using the forward slash character in usernames intended for provisioning use cases.

Loading
Org2Org Sync Issue for User with a Slash in ID