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Okta Login not Working for Username or Password using Apple Mobile Devices
Okta Classic Engine
Okta Identity Engine
Administration
Overview
Sign-on to Okta is not working when using usernames or passwords with certain special characters on Apple mobile devices, such as iPhones or iPads. During the login attempt, the users will receive one of the following errors: 
 
  • VERIFICATION_ERROR
or 
  • INVALID_CREDENTIALS
Applies To
  • iOS Devices
  • Okta Classic Engine
  • Okta Identity Engine (OIE)
Cause
Starting in iOS 11, Apple enables Smart Punctuation by default. This feature is designed to make writing more elegant, by transposing characters automatically. Known characters include the following:
  • The apostrophe or single-quote ( ' ) is substituted for a slanted smart-quote ( ).
  • The straight double-quotation ( " ) is substituted for a slanted double smart-quote ( ).
  • Two sequential dashes/hyphens ( -- ) are substituted for an em dash ( ).
  • Three sequential periods ( ... ) are substituted for an ellipsis ( ).
Solution

Choose one of the following options:

  1. On the iPhone, turn off Smart Punctuation by navigating to Settings > General > Keyboard > Smart Punctuation.
    • To retain Smart Punctuation, press the single quote key on the keyboard and select the valid apostrophe key from the list.
  2. In the password field, tap the eye icon to "Show password" and enter the password manually. This reliably allows 1:1 character entry with no substitutions.
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Okta Login not Working for Username or Password using Apple Mobile Devices