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Okta AD Agent Infrequently Disconnects from Okta
Okta Classic Engine
Directories
Okta Identity Engine
Overview

The Okta Active Directory (AD) agent disconnects from the Okta org when the host server reboots, and Okta reports no errors. Validate the host server reboot status in the Windows Event Viewer to verify the cause of agent service disruption.

 

The AD agent logs display the following messages associated with a service restart:

2020/01/15 09:29:05.500-08:00 Debug -- Server(10) -- Agent Uptime: 27 day(s) 22:44:34
2020/01/15 09:29:05.500-08:00 Info -- Server(10) -- Checking if the target domain can be contacted
2020/01/15 09:29:05.500-08:00 Info -- Server(10) -- Retrieving next action
2020/01/15 09:29:05.500-08:00 Debug -- Server(10) -- GET: https://{{oktaSubdomain}}.oktapreview.com/api/1/internal/app/activedirectory/{{appID}}/agent/{{agentID}}/nextAction?agentVersion=3.5.9.0&pollid={{pollID}}
2020/01/15 09:29:05.500-08:00 Debug -- Server(10) -- GetResponse starting, CurrentConnections:10, ConnectionLimit:50, Timeout:33000, ReadWriteTimeout:300000, KeepAlive:True, ConnectionLeaseTimeout:300000.
2020/01/15 09:35:18.444-08:00 Info -- Server(4) -- Logging configuration: maximum file size is 5000000 bytes, keep 10 old file(s)
2020/01/15 09:35:19.020-08:00 Info -- Server(4) -- Okta AD Agent starting
2020/01/15 09:35:19.036-08:00 Info -- Server(4) -- Configured unhandled exception handler.
2020/01/15 09:35:19.036-08:00 Info -- Server(4) -- Loading configuration file: C:\Program Files (x86)\Okta\Okta AD Agent\OktaAgentService.exe

 

Applies To
  • Okta Identity Engine (OIE)
  • Okta Classic Engine
  • Directories
  • Active Directory (AD)
  • Okta AD agent
Cause

Infrequent disconnections that do not produce errors in the AD agent logs typically indicate a host server reboot.

Solution

How is the host server reboot status validated?

 

To validate the host server reboot status, check the Windows Event Viewer for specific event IDs and consult the appropriate support teams if necessary.

  1. Validate if a Microsoft patch update and subsequent restart caused the host server to reboot.
  2. Open Event Viewer and navigate to Windows Logs > System on the Windows server.
  3. Search for event ID 1074 generated by User32 to view details on the last server reboot.
  4. Consult with the Active Directory team or Microsoft Support if evidence shows the machine restarting.

 

NOTE: If evidence does not show the host machine restarting, review the Okta Active Directory Agent Disconnects With "Error Retrieving Next Action" Timeout article for further troubleshooting.

 

Related References

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Okta AD Agent Infrequently Disconnects from Okta