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Microsoft Office 365 Provisioning Error "400 Unable to assign this license"
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Microsoft Office 365 provisioning flow fails with the following error visible in the Okta dashboard:

Could not push profile for Office 365 user [username], received error: 400 Unable to assign this license. Please fix this on the Tasks Page

 

Applies To
  • Microsoft Office 365
  • Okta Integration Network (OIN)
  • Provisioning
  • Error
Cause

The error 400, "Unable to assign this license," occurs because the licenses stored against the app profile no longer accurately reflect one or more licenses on the Office portal.

Solution

To resolve this error, perform an application refresh. This operation will download the licenses from Office and their respective resource IDs, allowing Okta to have the correct listing.

  • Go to the Applications section in the Okta admin panel.
  • Click the More button.
  • Select the Refresh Application Data option.

See screenshot:

Refresh Application Data

  • Wait 1–5 minutes to ensure the data is refreshed.
  • Retry the license assignment.

NOTE: Refreshing the Application Data will trigger data retrieval for all the applications in the Okta tenant, not just Office 365.

If only licenses for Office 365 are required, other options include:

  • Reauthenticate the API credentials from the Provisioning > API Integration.
  • Perform an import.
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Microsoft Office 365 Provisioning Error "400 Unable to assign this license"