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Microsoft Office 365 User Not Deprovisioned after Encountering a Provisioning Error Due to Licensing

Okta Classic Engine
Okta Identity Engine
Okta Integration Network

Overview

A provisioning error might be encountered due to licensing seats being exceeded still get created in Azure, just without a license.

Applies To

  • Microsoft Office 365 (O365)
  • Azure AD
  • Provisioning
  • License Provisioning

Cause

  • Removing the account from the Office 365 application in Okta does not trigger the "Push user deactivation to external application" event.
  • Microsoft Limitation: The MS Graph library that Okta is leveraging does not support clearing the on-premise immutable ID. 

Solution

The licensing issue may be addressed by one of the following methods:

  • Removing the licenses from the user assignment.
  • Purchasing the Microsoft license.

Once the licensing issue has been addressed, retry the account provisioning process. Once the account has been successfully provisioned, it will follow the expected behavior where the Azure/Office 365 user will be deactivated if removed from the OIN Office 365 application in Okta.

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Okta Support - Microsoft Office 365 User Not Deprovisioned after Encountering a Provisioning Error Due to Licensing