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Office 365 Provisioning Error "Could not resolve request to a valid role template"
Okta Integration Network
Overview

Office 365 provisioning flow fails with the following error visible in the Okta dashboard:

One of the Office 365 roles assigned to this user does not exist in Office 365. You may be able to fix this by clicking the Refresh Application Data button on the Applications page in the Okta admin console. Detailed error: Could not resolve request to a valid role template. httpStatusCode=400 errorCode=Request_BadRequest errorMessage="Could not resolve request to a valid role template. A valid value must be specified for 'displayName' or 'roleTemplateId'.
 

Error

 

Applies To
  • Office 365
  • Provisioning
  • Error
Cause
Usually, this means that the user was assigned to the Office 365 application with roles that are no longer used within Microsoft.
Solution

Ensure the roles are available in the Microsoft tenant and properly assigned to the affected user in Okta. Then, retry the failed provisioning task.


If the error persists, please contact Microsoft support for more details.

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Office 365 Provisioning Error "Could not resolve request to a valid role template"