Okta Identity Engine Upgrade Blocked by Invalid Okta Verify Enrollment Settings
Last Updated:
Overview
The following reconfiguration has been identified as part of the preparation needed to perform the upgrade to Okta Identity Engine (OIE).
NOTE: Additional Okta features may require reconfiguration or be disabled in order to complete the upgrade. Any org that has an enrollment policy that has Okta Verify Push enabled and Okta Verify OTP disabled is blocked from upgrading.
Applies To
- Okta Verify
- Multi-Factor Authentication (MFA)
Cause
The upgrade is blocked because an authenticator enrollment policy has Okta Verify Push enabled while Okta Verify One-Time Password (OTP) is disabled. This configuration is not valid for the upgrade process.
Solution
There are two methods to resolve this issue.
Using the Admin Console
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In the Admin Console, go to the authenticator enrollment policy that is causing the issue.
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Edit the policy.
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Toggle Okta Verify from disabled to enabled.
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Clear the Push checkbox.
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Toggle Okta Verify back from enabled to disabled.
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Select Save.
Using Management Policy API
- Use the policy management API method GET to endpoint list the enrollment policies:
https://${yourOktaDomain}/api/v1/policies?type=MFA_ENROLL -
In the response, locate the policy where the
okta_otpsetting has a"self": "NOT_ALLOWED"value. -
In the same policy, verify that the
okta_pushsetting isOPTIONALorREQUIRED. If both conditions are met, this policy is the cause of the issue. -
If the identified policy is the Default Policy, modify it using the steps described in the Using the Admin Console section.
