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Okta Access Gateway: Unable to Save Application Changes
Access Gateway
Overview

Okta Access Gateway (OAG) shows an error message when saving a specific application. Editing/saving on other applications works fine.

 

This event has been logged.

Server has encountered an error updating the application.

 

Server Side Error occured

Server side exception has been logged.

Please notify support.



OAG Error 

 

OAG logs show the below error message when the issue happens:

 

errors:[ERROR:[errorCode:E0000024, errorSummary:Bad request.  This operation on app metadata is not yet supported., errorLink:E0000024, errorId:*****-*********, errorCauses:[[errorSummary:This operation on app metadata is not yet supported: No active instances.]]]], context:null)

 

Applies To
  • Okta Access Gateway (OAG)
Cause

When saving an Active application from OAG, it sends the template to Okta and expects the application to be Active there. In case the application is deactivated in Okta, then OAG would not be able to save it and throw the error above in logs. It complains about "No active instances".

Solution

Use one of the two solutions mentioned below to resolve the issue:

  • Solution 1: Activate the application in Okta. OAG can then save the application when the user tries again.
  • Solution 2: From OAG, make the application inactive. This will trigger the deactivation flow on the Okta side. Switching the application to active in OAG will then resolve the issue.
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Okta Access Gateway: Unable to Save Application Changes