<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Unable to Sign Out from Desktop SSO
Single Sign-On
Okta Classic Engine
Overview
When using Desktop Single Sign-On (DSSO) or Agentless Desktop Single Sign-On (ADSSO), users cannot sign out of Okta and will be automatically re-authenticated.
Applies To
  • Desktop Single Sign-On (DSSO)
  • Agentless Desktop Single Sign-on (ADSSO)
  • Okta Classic Engine
Cause
When a user signs out of Okta, they are redirected to the Okta sign-in page. However, since DSSO/ADSSO is enabled, the user's computer will automatically start the authentication process again, causing the user to be re-authenticated.
Solution

In this video, learn how to sign out of desktop SSO without re-authenticating.


To resolve this issue, follow these steps:

  1. Log in to the Okta admin dashboard.

  2. Click Customizations > Other​​​​​​.

  3. Find the Sign-Out Page configuration and click Edit.

  4. Select the Use a custom sign-out page and enter the URL that users will be redirected to after signing out of Okta. If requiring users to be redirected to the Okta sign-in page without being automatically re-authenticated, use the following URL:
    https//:{{Your_Company_Subdomain]}.okta.com/login/default

Customizations 
 

NOTE: The default behavior in Okta is to use a cookie to maintain a user's signed-in status. To automatically sign users out when they close their browser, modify the "Session Lifetime" setting in Okta. Changing this setting can impact other functionalities in Okta, such as SAML SSO.

Loading
Unable to Sign Out from Desktop SSO