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Newly Created Values for Salesforce Profile or Role Attributes are Not Visible in Okta
Lifecycle Management
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview
In the event that newly created Roles and Profiles for Salesforce do not yet display within Okta while attempting to assign them to new users/groups or editing assignments for currently assigned users, it is indicative of the app data within Okta being outdated and necessitates a refresh.
Applies To
  • Salesforce
Cause

The Salesforce application data has not been updated in Okta.

Solution

Use one of the following methods:

Method 1

  1. Navigate to the Okta Admin Console. 
  2. Navigate to Applications menu > Applications tab. 
  3. Click More to select Refresh Application Data (NOTE: this will trigger an import of application data for all applications configured with Provisioning):

Refresh Application Data


Method 2

Re-authenticate API credentials that are used for provisioning to/from Salesforce, and make sure the OAuth Consumer Key and Secret are correct. This will cause the download and updating of the application data into Okta (this will only refresh the application data for Salesforce):

  1. Go to the Okta Admin Console and navigate to Applications > Salesforce > Provisioning > Integration.

  2. Click on the Reauthenticate button  button.
  3. A new window will open. Log in with the account used for provisioning and press Save.

Integration 

 
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Newly Created Values for Salesforce Profile or Role Attributes are Not Visible in Okta