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MFA not Prompting for Microsoft Office 365 Thick Clients (Desktop Applications)

Multi-Factor Authentication

Overview

This article explains a potential reason a user may not receive a Multi-factor Authentication (MFA) prompt for a Microsoft 365 thick client application.

  • Within Okta, a valid app sign-on policy for 365 exists, and users are prompted for MFA when logging in via the web.

Applies To

  • Microsoft Office 365 (O365)
  • App sign-on policies
  • Any OS or browser

Cause

For thick clients supporting MFA, the individual app or service determines how frequently they are directed back to Okta for authentication. The 'JSON refresh token period' for the Desktop/Thick clients defaults to 14-90 days.

Note: The JSON token authenticates the user each time, and NOT a new authentication call to Okta.

For Microsoft Office apps refresh intervals, see Session timeouts for Office 365.

Solution

  1. Revoke the session manually
    • Access Microsoft 365 admin center > Azure > users > select the user > press Revoke Sessions under that user's profile. Press the desktop application. Now, a prompt for Okta MFA should be seen.

  1. Update the session token


Related References

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Okta Support - MFA not Prompting for Microsoft Office 365 Thick Clients (Desktop Applications)