MFA Login Page Does Not Load with IDP for MFA Enabled
Okta Classic Engine
Multi-Factor Authentication
Overview

This article provides a solution for an issue where users are unable to load the MFA page during login while using IDP for MFA and a custom login user interface. The Multi-Factor Authentication (MFA) request page keeps loading.

Applies To
  • IDP for Multi-Factor Authentication (MFA)
  • Okta Sign-in Widget
  • Custom UI
Cause

The Okta Sign-in Widget version is not up to date.

Solution

Update the Okta sign-in Widget to the latest major and minor versions in Okta:

To update the widget:

  1. On the Admin Dashboard, go to Customizations > Brands.
    1. If using a custom domain, at least two brands should be seen: one is the Okta-provided domain [subdomain.okta.com], and the other is the custom domain name. Select the brand that uses the custom domain.
    2. From there, a few tabs should be seen at the top.  Select Pages.
    3. The Sign-in Page should be an option seen next to the End-User Dashboard and Error Pages. Click Configure under the Sign-in Page.
    4. Select the Settings tab at the top of the page, and there should be a space for the Sign-in Widget Version.
  2. In the Okta Sign-In Widget Version section, check that the Major Version is the highest version available and the Minor Version is the latest. The widget is always the latest version, unless a custom URL domain is used.
  3. If using the custom URL domain feature and the version is not correct, change the widget's version. Click Edit in the Okta Sign-In Widget Version section and then select the Major Version and Minor Version fields.
  4. Click Save at the bottom of the page.

 

Okta Identity Engine

Brands

 

 

Okta Classic Engine

Brands

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