<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content

Jamf Configuration Profiles Stuck Pending with System Log Error "Issue client certificatefailure: Error while issuing a ClientCertificate via SCEP: Subject CN cannot be null"

Devices and Mobility

Overview

In the following document, Configure Okta as a CA with dynamic SCEP challenge for macOS using Jamf Pro/Task 2: Create a dynamic SCEP profile in Jamf Pro, Jamf Configuration Profiles get Stuck Pending with concurrent system log error:

Issue client certificate failure: Error while issuing a ClientCertificate via SCEP: Subject CN cannot be null

Applies To

  • Okta Identity Engine
  • Device Trust
  • JAMF

Cause

The "Subject:" on the SCEP profile page in Jamf is empty or does not begin with CN =

Loading
Okta Support - Jamf Configuration Profiles Stuck Pending with System Log Error "Issue client certificatefailure: Error while issuing a ClientCertificate via SCEP: Subject CN cannot be null"