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Invalid Session Error When Activating Rules via Postman
Administration
Okta Classic Engine
Okta Identity Engine
Overview

This article clarifies why an error occurs when running the Activate Rule call from the Groups (Okta API) collection in Postman. The issue is observed when attempting the following call:

POST /api/v1/policies/${policyId}/rules/${ruleId}/lifecycle/activate

The following error message is displayed in Postman:

 {

"errorCode": "E0000005",

"errorSummary": "Invalid session",

"errorLink": "E0000005",

"errorId": "<ERROR_ID>",

"errorCauses": []

}

For example:

Postman

Applies To
  • API
  • Postman
Cause

The Authorization configuration is missing in Postman.

Solution

Add Open Authorization (OAuth) 2.0 to Postman to resolve the session error.

  1. Follow the instructions in the article How to Integrate Postman with Okta to add the OAuth 2.0 Authorization to Postman.
  2. The authorization section should look like this.

Authorization Section

Related References

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Invalid Session Error When Activating Rules via Postman