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How to Troubleshoot and Resolve "Bad SAML Request" Error in Go To Meeting Classic Desktop App Authentication
Single Sign-On
Okta Classic Engine
Okta Identity Engine
Overview

This article provides guidance on how to troubleshoot and resolve the error:

 Bad SAML Request

This error occurs when trying to authenticate with the "Go To Meeting" classic desktop app.

Applies To
  • Security Assertion Markup Language (SAML)
  • SAML Errors
Cause

The Bad SAML Request error occurs when the authentication flow is interrupted due to a broken request. This can happen if the SAML Request included in the fromUri has a length limit, and some strings are dropped when the redirection happens.

Solution

To resolve this issue, migrate from Integrated Windows Authentication (IWA) to agentless Desktop Single Sign-on (DSSO). This is the best long-term solution to avoid encountering SAML request size limits. If that is not an option, reducing the size of the SAMLRequest by modifying the SAML Request Bind from POST to REDIRECT or disabling the signing of the SAML Request will also prevent the error message. These strategies can be adopted on the service provider (SP) side.


If either of these solutions is impossible, contact Okta Support for additional assistance.

 

Related References

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How to Troubleshoot and Resolve "Bad SAML Request" Error in Go To Meeting Classic Desktop App Authentication