Getting Error "403 Not Assigned App" when Attempting to Access the Okta Workflows Console
Last Updated:
Overview
Accessing the Okta Workflows console generates a 403 error if the administrator account lacks assignment to the required Workflows applications. Assigning the administrator account to both the Okta Workflows and Okta Workflows OAuth applications resolves the issue.
Okta generates one of the following error messages when the access attempt fails:
- Not Assigned App
Sorry, you can't access {0} because you are not assigned to this app in Okta. If you're wondering why this is happening, please contact your administrator.
- App Not Assigned
Sorry, you can't access Okta Workflows because you are not assigned this app in Okta. If you're wondering why this is happening, please contact your administrator.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Okta Workflows
Cause
The account utilizing a Super Admin, Workflows Admin, or Workflows Role-Based Access Control (RBAC) role lacks assignment to the Okta Workflows application.
Solution
How is the 403 Not Assigned App error resolved?
Resolve the 403 error by navigating to the Admin Console with a Super Admin account and assigning the account experiencing the issue to the Okta Workflows application:
- Navigate to the Admin Console.
- Go to Applications and select Applications.
- Assign the administrator account to the Okta Workflows application.
NOTE: Accessing workflows requires Super Admin or Workflows Admin privileges or RBAC for Workflows and must be maintained. See Get started with RBAC.
