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Facebook Workplace Provisioning and Deprovisioning Issues
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

An attempt to provision a user from Okta to Facebook Workplace fails with the following error:

Failed to update profile due to rate limiting job=xxxxxxx errorMessage=API rate
limit exceeded. Error occurred, we will retry in 3,600 sec

 

An attempt to deprovision an Okta user from Facebook Workplace does not succeed.
 

Applies To
  • Facebook Workplace app 
  • Push AD Manager Field in the Provisioning tab
  • Provisioning
Cause
AD query was querying the wrong user manager profile data.
Solution
  1. Uncheck the Push AD Manager Field on the Facebook Workplace app (Provisioning tab).
    Push AD Manager Field 
     

  2. Use the Universal Directory/Profile Editor based mapping to pass down the manager attribute using the expression getManagerUser("active_directory").email > facebookUser.manager:

    1. In the Okta Admin Console, navigate to Directory > Profile Editor.

    2. Next to the Facebook Workplace app, click Mappings.

    3. Click the Okta to Workplace by Facebook tab.

    4. Enter the expression getManagerUser("active_directory").email > facebookUser.manager in the Okta column next to the Facebook User.manager attribute.

 

If there is an Active Directory > Okta > Facebook configuration and the manager field does not update in Facebook after updating it in AD, follow the steps below:

  1. Add the getManagerUser("active_directory").email > facebookUser.manager as described above.

  2. Update the manager for any user in AD.

  3. Import changes to Okta.

  4. Ensure the corresponding Facebook user was updated with the new manager.

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Facebook Workplace Provisioning and Deprovisioning Issues