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Okta Identity Engine Upgrade Blocked by Workspace ONE iOS Device Trust
Administration
Okta Classic Engine
Okta Identity Engine
Overview

The following reconfiguration has been identified as part of the preparation needed to perform the upgrade to Okta Identity Engine (OIE). Note that additional Okta features may require reconfiguration or be disabled in order to complete the upgrade. The upgrade cannot proceed if Workspace ONE Security Assertion Markup Language (SAML) based Device Trust for iOS is enabled.

Applies To
  • Okta Identity Engine Upgrade
  • Device Trust
  • Workspace ONE
Cause

The upgrade to the Okta Identity Engine (OIE) is blocked because OIE does not support SAML-based device trust with Workspace ONE.

Solution

NOTE: As of June 11, 2024, the OIE upgrade blocker related to Workspace ONE SAML-based Mobile Device Trust has been resolved with the release of a new feature.

To resolve this upgrade blocker, enable the self-service feature designed for this migration.

  1. Enable the Migration Support for Workspace ONE Device Trust for Android and iOS self-service feature.

  2. Proceed with the upgrade to OIE.

Alternatively, if removing SAML-based device trust is the preferred path:

  1. Follow the guidance on disabling Mobile Device Trust.

  2. Once disabled, create a support ticket to have the feature removed from the organization.

 

Related References

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Okta Identity Engine Upgrade Blocked by Workspace ONE iOS Device Trust