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Email Notification Event Type Missing from System Log
Administration
Okta Classic Engine
Okta Identity Engine
Overview

When a user enrolls a Multi-Factor Authentication (MFA) factor, an automated email can be sent to notify them that a new factor was enrolled with their account. When that email is sent, it is logged in the system logs as the following event type: 

 

system.email.mfa_enroll_notification.sent_message.

 

This knowledge article addresses the reason why that event type is missing from the system log and provides a solution to the issue.

Applies To
  • Multi-Factor Authentication (MFA)
  • System Log
  • Email Notification
Cause

The option to send notification emails is disabled. If the option to send the notification emails is not enabled, the email notifications will not be sent, and the event will not be logged.

Solution

Okta Identity Engine (OIE)

  1. Access the Okta Admin Console.
  2. Navigate to Security > General.
  3. Under Security notification emails, click Edit.
  4. Modify the value for the Authenticator enrolled notification email to be Enabled.
  5. Click Save.

Security notification emails screenshot

 

Okta Classic

  1. Access the Okta Admin Console.
  2. Navigate to Security > General.
  3. Under Security notification emails, click Edit.
  4. Modify the value for MFA enrolled notification email to Enabled.
  5. Click Save.

Security notification emails Okta Classic screenshot


Related References

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Email Notification Event Type Missing from System Log