Error: "Invalid self service recovery token used by user"
Administration
Okta Identity Engine
Overview

This knowledge article aims to clarify why a user receives the following errors in the System Log when using the Self-Service Unlock/Password Reset feature.

Invalid self service recovery token used by user

failure: Invalid token


Invalid token

or

Fired when the user's Okta password is reset

FAILURE: Invalid token

Invalid token

Applies To
  • Self-service Unlock
  • Self-service Password Reset
Cause

The error is related to self-service unlock/password reset tokens when a user performs a self-service request via the Email option and is issued a link to reset their password. The following scenarios can result in the error:

  • When the email link/token has been previously used successfully to perform an Account Unlock/Password Reset, and a user reaccesses the link at some later point in time.
  • When the Account Unlock/Password Reset link has expired.
  • When accessing the same Account Unlock/Password Reset link, modify the recovery token (to some invalid token that Okta has not stored).
Solution
Create a new recovery token by repeating the Self Serice Password Request flow or the Self Service Unlock flow, and make sure to use the Reset/Unlock link before it expires. Also, remember that the links can be used only once. If a user gets locked out again or requires another password reset in a short time span, a new recovery flow should be performed.

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