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Button for Edit Personal Information Fields is Missing in End Users' Okta Profile Settings
Administration
Okta Classic Engine
Okta Identity Engine
Overview

Active Directory (AD)-mastered users do not see the Edit button for Personal Information fields in their profile settings when Secondary Email is set to Disabled from the Okta Admin Console (Customizations > Other > Optional User Account Fields).

 

Optional User Account Fields

Applies To
  • AD-mastered users
  • Okta Profile
  • Optional User Account Fields
Cause
The Optional User Account Field for Secondary Email is a legacy function that was necessary to implement for AD-mastered users in order to allow them to fill in their own secondary emails. When the option is disabled, it simply removes the Edit button for the end user because there was only one attribute at the time. When Okta introduced Attribute Level Mastering, the number of attributes for AD-mastered users that could potentially be mastered by Okta (or other Profile Masters) was limitless, so we introduced the User Permissions feature. This allows much more control over how the end users can interact with attributes that are inherited by Okta.

The legacy function still operates as it was originally intended.
Solution

For organizations with Attribute-Level Mastering, admins should leverage the User Permission to "Hide" Secondary Email (which will make the Secondary Email attribute hidden/unavailable for users), instead of disabling it from the customization page.

 

Related References

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Button for Edit Personal Information Fields is Missing in End Users' Okta Profile Settings